What to use instead of the 'new' statement in bukkit plugins/java

Well, I'm tring to make a bukkit plugin that checks for a YAML file called 'config.yml' but to do that I would need to do:

Config = new File(this.getDataFolder(), "config.yml");
Configs = YamlConfiguration.loadConfiguration(Config);

But, that also creates it if it doesn't exist.

Jon Skeet
people
quotationmark

I suspect you just want:

if (Config.exists()) {
    Configs = YamlConfiguration.loadConfiguration(Config);
}

(Now would be a good time to learn about Java naming conventions, by the way - variables in Java conventionally start with a lower-case letter.)

people

See more on this question at Stackoverflow